# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\b(?:typedef struct|typedef|struct)\b
[^;{}]+
(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?
;
"""
test_str = ("\n"
"typedef struct SS__DD WEFGEGWEG;\n"
" \n"
"struct SS__DD WEFGEGWEG;\n"
" \n"
"typedef struct SS__DD {\n"
" DFBFFN *trait_method;\n"
" union {\n"
" HRTRTH *cRTNe;\n"
" RTHR 56J56;\n"
" } *SEGWEG;\n"
"} WEFGEGWEG; \n"
" \n"
"typedef struct SS__DD {\n"
" DFBFFN *trait_method;\n"
" union {\n"
" HRTRTH *cRTNe;\n"
" RTHR 56J56;\n"
" } *SEGWEG;\n"
"} WEFGEGWEG, WEFGE4Y45Y; \n"
" \n"
" \n"
"typedef struct SS__DD {\n"
" DFBFFN *trait_method;\n"
" union {\n"
" HRTRTH *cRTNe;\n"
" RTHR 56J56;\n"
" } *SEGWEG;\n"
"}; \n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.