use strict;
my $str = '
typedef struct SS__DD WEFGEGWEG;
struct SS__DD WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG, WEFGE4Y45Y;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
};
';
my $regex = qr/\b(?:typedef struct|typedef|struct)\b
[^;{}]+
(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?
;/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}