import Foundation
let pattern = #"""
\b(?:typedef struct|typedef|struct)\b
[^;{}]+
(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?
;
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
typedef struct SS__DD WEFGEGWEG;
struct SS__DD WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG, WEFGE4Y45Y;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
};
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)