// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\b(?:typedef struct|typedef|struct)\b
[^;{}]+
(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?
;").unwrap();
let string = "
typedef struct SS__DD WEFGEGWEG;
struct SS__DD WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG, WEFGE4Y45Y;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
};
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}