const regex = /\b(?:typedef struct|typedef|struct)\b
[^;{}]+
(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?
;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:typedef struct|typedef|struct)\\b
[^;{}]+
(?: ( \\{ (?: [^{}]++ | (?1) )+ \\} ) [^;]* )?
;', 'g')
const str = `
typedef struct SS__DD WEFGEGWEG;
struct SS__DD WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG, WEFGE4Y45Y;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
};
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}