# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\*\s+(?<text>[^\]]+)\]/<ref>$text<\/ref>/g;t' <<< "Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]"