// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\*\s+(?<text>[^\]]+)\]").unwrap();
let string = "Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]";
let substitution = "<ref>$text</ref>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}