#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[\*\s+(?<text>[^\]]+)\]"
Local $sString = "Should not match [*A]" & @CRLF & _
"" & @CRLF & _
"Should not match [*refname]" & @CRLF & _
"" & @CRLF & _
"Should not match [*A text] as it is already done in the step before." & @CRLF & _
"" & @CRLF & _
"But should match [* This is the text in the ref]"
Local $sSubst = "<ref>$text</ref>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)