using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\*\s+(?<text>[^\]]+)\]";
string substitution = @"<ref>$text</ref>";
string input = @"Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}