use strict;
my $str = 'Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]';
my $regex = qr/\[\*\s+(?<text>[^\]]+)\]/p;
my $subst = '<ref>$text</ref>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";