import Foundation
let pattern = #"\[\*\s+(?<text>[^\]]+)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<ref>$text</ref>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)