import re
regex = re.compile(r"\[\*\s+(?<text>[^\]]+)\]")
test_str = ("Should not match [*A]\n\n"
"Should not match [*refname]\n\n"
"Should not match [*A text] as it is already done in the step before.\n\n"
"But should match [* This is the text in the ref]")
subst = "<ref>$text</ref>"
result = regex.sub(subst, test_str)
if result:
print(result)