import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-4](?:\\.\\d+)?|5(?:\\.0+)?)$";
final String string = "Do match (Expectation):\n\n"
+ "1\n"
+ "1.5\n"
+ "1.584\n"
+ "2\n"
+ "4.68756\n"
+ "5\n"
+ "Don't match (Expectation):\n\n"
+ "0\n"
+ ".5\n"
+ "0.99\n"
+ "01\n"
+ "05\n"
+ "5.1\n"
+ "6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}