use strict;
my $str = 'Do match (Expectation):
1
1.5
1.584
2
4.68756
5
Don\'t match (Expectation):
0
.5
0.99
01
05
5.1
6';
my $regex = qr/^(?:[1-4](?:\.\d+)?|5(?:\.0+)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}