const regex = /^(?:[1-4](?:\.\d+)?|5(?:\.0+)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-4](?:\\.\\d+)?|5(?:\\.0+)?)$', 'gm')
const str = `Do match (Expectation):
1
1.5
1.584
2
4.68756
5
Don't match (Expectation):
0
.5
0.99
01
05
5.1
6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}