$re = '/^(?:[1-4](?:\.\d+)?|5(?:\.0+)?)$/m';
$str = 'Do match (Expectation):
1
1.5
1.584
2
4.68756
5
Don\'t match (Expectation):
0
.5
0.99
01
05
5.1
6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);