# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\(\d+,\d+,'[\d\w]+',\d+,\d+,\d+,\d+,\d+,\d+,\d+\))(,(\(\d+,\d+,'[\d\w]+',\d+,\d+,\d+,\d+,\d+,\d+,\d+\))|,{,1})*$//gms;t' <<< "(2,3,'men1',56,45,45,45,45,45,5),(2,3,'men1',6,45,45,45,45,45,45)"