import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\(\\d+,\\d+,'[\\d\\w]+',\\d+,\\d+,\\d+,\\d+,\\d+,\\d+,\\d+\\))(,(\\(\\d+,\\d+,'[\\d\\w]+',\\d+,\\d+,\\d+,\\d+,\\d+,\\d+,\\d+\\))|,\\{,1\\})*$";
final String string = "(2,3,'men1',56,45,45,45,45,45,5),(2,3,'men1',6,45,45,45,45,45,45)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}