# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+?)(?:( - ))(.+)(?:( - ))(.+)/$1 ! $3 ! $5/gmi;t' <<< "Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc
Someb0dy S'ome-where - Some silly rubbish - More blah - finaly the title.ext
Author, Name - Series 00 - Title.ext"