const regex = new RegExp('^(.+?)(?:( - ))(.+)(?:( - ))(.+)', 'gmi')
const str = `Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc
Someb0dy S'ome-where - Some silly rubbish - More blah - finaly the title.ext
Author, Name - Series 00 - Title.ext`;
const subst = `$1 ! $3 ! $5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);