use strict;
my $str = 'Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc
Someb0dy S\'ome-where - Some silly rubbish - More blah - finaly the title.ext
Author, Name - Series 00 - Title.ext';
my $regex = qr/^(.+?)(?:( - ))(.+)(?:( - ))(.+)/mip;
my $subst = '$1 ! $3 ! $5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";