import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)(?:( - ))(.+)(?:( - ))(.+)";
final String string = "Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc\n"
+ "Someb0dy S'ome-where - Some silly rubbish - More blah - finaly the title.ext \n"
+ "Author, Name - Series 00 - Title.ext";
final String subst = "$1 ! $3 ! $5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}