package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(.+?)(?:( - ))(.+)(?:( - ))(.+)`)
var str = `Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc
Someb0dy S'ome-where - Some silly rubbish - More blah - finaly the title.ext
Author, Name - Series 00 - Title.ext`
var substitution = "$1 ! $3 ! $5"
fmt.Println(re.ReplaceAllString(str, substitution))
}