# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.+?)(?:( - ))(.+)(?:( - ))(.+)"
test_str = ("Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc\n"
"Someb0dy S'ome-where - Some silly rubbish - More blah - finaly the title.ext \n"
"Author, Name - Series 00 - Title.ext")
subst = "$1 ! $3 ! $5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.