#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(.+?)(?:( - ))(.+)(?:( - ))(.+)"
Local $sString = "Ann M Martin - Baby sitters Club - Baby sitters Little Sister - Super Special 04 - Karen, Hannie and Nancy - The Three Musketeers.doc" & @CRLF & _
"Someb0dy S'ome-where - Some silly rubbish - More blah - finaly the title.ext " & @CRLF & _
"Author, Name - Series 00 - Title.ext"
Local $sSubst = "$1 ! $3 ! $5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)