using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(2[0-3]|1?[0-9])?(\.[0-5]?[0-9])?$";
string input = @"0
1
.58
.59
.60
.123
23.1
23.59
24
24.0
24.01
123
123.
.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}