use strict;
my $str = '0
1
.58
.59
.60
.123
23.1
23.59
24
24.0
24.01
123
123.
.';
my $regex = qr/^(2[0-3]|1?[0-9])?(\.[0-5]?[0-9])?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}