import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(2[0-3]|1?[0-9])?(\\.[0-5]?[0-9])?$";
final String string = "0\n"
+ "1\n"
+ ".58\n"
+ ".59\n"
+ ".60\n"
+ ".123\n"
+ "23.1\n"
+ "23.59\n"
+ "24\n"
+ "24.0\n"
+ "24.01\n"
+ "123\n"
+ "123.\n"
+ ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}