$re = '/^(2[0-3]|1?[0-9])?(\.[0-5]?[0-9])?$/m';
$str = '0
1
.58
.59
.60
.123
23.1
23.59
24
24.0
24.01
123
123.
.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);