using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*Tag4).*\/Group1\/.*";
string input = @"/Group1/Tag1
/Group1/Tag2
/Group1/Tag3
/Group1/GroupVoltage/Tag1
/Group1/GroupVoltage/Tag2
/Group1/GroupVoltage/Tag3
/Group1/GroupVoltage/Tag4
/Group2/Tag1
/Group2/Tag2
/Group2/Tag3
/Group2/GroupVoltage/Tag1
/Group2/GroupVoltage/Tag2
/Group2/GroupVoltage/Tag3
/Group2/GroupVoltage/Tag4
/Group3/Tag1
/Group3/Tag2
/Group3/Tag3
/Group3/GroupVoltage/Tag1
/Group3/GroupVoltage/Tag2
/Group3/GroupVoltage/Tag3
/Group3/GroupVoltage/Tag4
/Group4/Tag1
/Group4/Tag2
/Group4/Tag3
/Group4/GroupVoltage/Tag1
/Group4/GroupVoltage/Tag2
/Group4/GroupVoltage/Tag3
/Group4/GroupVoltage/Tag4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}