const regex = /^(?!.*Tag4).*\/Group1\/.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*Tag4).*\\\/Group1\\\/.*', 'gm')
const str = `/Group1/Tag1
/Group1/Tag2
/Group1/Tag3
/Group1/GroupVoltage/Tag1
/Group1/GroupVoltage/Tag2
/Group1/GroupVoltage/Tag3
/Group1/GroupVoltage/Tag4
/Group2/Tag1
/Group2/Tag2
/Group2/Tag3
/Group2/GroupVoltage/Tag1
/Group2/GroupVoltage/Tag2
/Group2/GroupVoltage/Tag3
/Group2/GroupVoltage/Tag4
/Group3/Tag1
/Group3/Tag2
/Group3/Tag3
/Group3/GroupVoltage/Tag1
/Group3/GroupVoltage/Tag2
/Group3/GroupVoltage/Tag3
/Group3/GroupVoltage/Tag4
/Group4/Tag1
/Group4/Tag2
/Group4/Tag3
/Group4/GroupVoltage/Tag1
/Group4/GroupVoltage/Tag2
/Group4/GroupVoltage/Tag3
/Group4/GroupVoltage/Tag4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}