import Foundation
let pattern = #"^(?!.*Tag4).*\/Group1\/.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/Group1/Tag1
/Group1/Tag2
/Group1/Tag3
/Group1/GroupVoltage/Tag1
/Group1/GroupVoltage/Tag2
/Group1/GroupVoltage/Tag3
/Group1/GroupVoltage/Tag4
/Group2/Tag1
/Group2/Tag2
/Group2/Tag3
/Group2/GroupVoltage/Tag1
/Group2/GroupVoltage/Tag2
/Group2/GroupVoltage/Tag3
/Group2/GroupVoltage/Tag4
/Group3/Tag1
/Group3/Tag2
/Group3/Tag3
/Group3/GroupVoltage/Tag1
/Group3/GroupVoltage/Tag2
/Group3/GroupVoltage/Tag3
/Group3/GroupVoltage/Tag4
/Group4/Tag1
/Group4/Tag2
/Group4/Tag3
/Group4/GroupVoltage/Tag1
/Group4/GroupVoltage/Tag2
/Group4/GroupVoltage/Tag3
/Group4/GroupVoltage/Tag4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)