#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^)|(.))adchoice."
Local $sString = "### this is probably what you want to block" & @CRLF & _
"adchoice.com" & @CRLF & _
"aadchoice.com" & @CRLF & _
"0adchoice.com" & @CRLF & _
"2adchoice.com" & @CRLF & _
"anystring-adchoice.com" & @CRLF & _
"www.adchoice.com" & @CRLF & _
"" & @CRLF & _
"### this is probably not what you want" & @CRLF & _
"badchoices" & @CRLF & _
"www.mybadchoice.com" & @CRLF & _
"madchoices.com" & @CRLF & _
"www.badchoice.in # (real domain)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")