const regex = /((^)|(.))adchoice./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^)|(.))adchoice.', 'gm')
const str = `### this is probably what you want to block
adchoice.com
aadchoice.com
0adchoice.com
2adchoice.com
anystring-adchoice.com
www.adchoice.com
### this is probably not what you want
badchoices
www.mybadchoice.com
madchoices.com
www.badchoice.in # (real domain)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}