use strict;
my $str = '### this is probably what you want to block
adchoice.com
aadchoice.com
0adchoice.com
2adchoice.com
anystring-adchoice.com
www.adchoice.com
### this is probably not what you want
badchoices
www.mybadchoice.com
madchoices.com
www.badchoice.in # (real domain)';
my $regex = qr/((^)|(.))adchoice./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}