$re = '/((^)|(.))adchoice./m';
$str = '### this is probably what you want to block
adchoice.com
aadchoice.com
0adchoice.com
2adchoice.com
anystring-adchoice.com
www.adchoice.com
### this is probably not what you want
badchoices
www.mybadchoice.com
madchoices.com
www.badchoice.in # (real domain)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);