import re
regex = re.compile(r"((^)|(.))adchoice.", flags=re.MULTILINE)
test_str = ("### this is probably what you want to block\n"
"adchoice.com\n"
"aadchoice.com\n"
"0adchoice.com\n"
"2adchoice.com\n"
"anystring-adchoice.com\n"
"www.adchoice.com\n\n"
"### this is probably not what you want\n"
"badchoices\n"
"www.mybadchoice.com\n"
"madchoices.com\n"
"www.badchoice.in # (real domain)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")