package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^)|(.))adchoice.`)
var str = `### this is probably what you want to block
adchoice.com
aadchoice.com
0adchoice.com
2adchoice.com
anystring-adchoice.com
www.adchoice.com
### this is probably not what you want
badchoices
www.mybadchoice.com
madchoices.com
www.badchoice.in # (real domain)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}