# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!^)|^\+@lin\+)\t/$1@tab+/gm;t' <<< "+@lin+'select 1,''hello'''
+@lin+'from-- two tabs exist after from'
+@lin+
+@lin+ 'table1'"