import Foundation
let pattern = #"(\G(?!^)|^\+@lin\+)\t"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+@lin+'select 1,''hello'''
+@lin+'from-- two tabs exist after from'
+@lin+
+@lin+ 'table1'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1@tab+"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)