re = /(\G(?!^)|^\+@lin\+)\t/m
str = '+@lin+\'select 1,\'\'hello\'\'\'
+@lin+\'from-- two tabs exist after from\'
+@lin+
+@lin+ \'table1\''
subst = '$1@tab+'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result