$re = '/(\G(?!^)|^\+@lin\+)\t/m';
$str = '+@lin+\'select 1,\'\'hello\'\'\'
+@lin+\'from-- two tabs exist after from\'
+@lin+
+@lin+ \'table1\'';
$subst = "$1@tab+";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;