using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\G(?!^)|^\+@lin\+)\t";
string substitution = @"$1@tab+";
string input = @"+@lin+'select 1,''hello'''
+@lin+'from-- two tabs exist after from'
+@lin+
+@lin+ 'table1'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}