#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\G(?!^)|^\+@lin\+)\t"
Local $sString = "+@lin+'select 1,''hello'''" & @CRLF & _
"+@lin+'from-- two tabs exist after from'" & @CRLF & _
"+@lin+" & @CRLF & _
"+@lin+ 'table1'"
Local $sSubst = "$1@tab+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)