#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<workspace>(@[\w-]*)?)//(?P<package>[\w\-/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\w\-\./]+)|(?P<target_recursive>\.\.\.)|(?P<empty_target>(?<!/)))$"
Local $sString = "@saicny_robotics//devices/realsense:all" & @CRLF & _
"@saicny_robotics//devices/realsense/:all" & @CRLF & _
"@//devices/realsense/..." & @CRLF & _
"//..." & @CRLF & _
"@spybot//..." & @CRLF & _
"@spybot//:all" & @CRLF & _
"@spybot//devices/realsense" & @CRLF & _
"@spybot//devices/realsense/" & @CRLF & _
"@spybot//:path/to" & @CRLF & _
"@spybot//devices/realsense:path_to/file.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")