re = /(?P<workspace>(@[\w-]*)?)\/\/(?P<package>[\w\-\/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\w\-\.\/]+)|(?P<target_recursive>\.\.\.)|(?P<empty_target>(?<!\/)))$/m
str = '@saicny_robotics//devices/realsense:all
@saicny_robotics//devices/realsense/:all
@//devices/realsense/...
//...
@spybot//...
@spybot//:all
@spybot//devices/realsense
@spybot//devices/realsense/
@spybot//:path/to
@spybot//devices/realsense:path_to/file.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end