using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<workspace>(@[\w-]*)?)//(?P<package>[\w\-/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\w\-\./]+)|(?P<target_recursive>\.\.\.)|(?P<empty_target>(?<!/)))$";
string input = @"@saicny_robotics//devices/realsense:all
@saicny_robotics//devices/realsense/:all
@//devices/realsense/...
//...
@spybot//...
@spybot//:all
@spybot//devices/realsense
@spybot//devices/realsense/
@spybot//:path/to
@spybot//devices/realsense:path_to/file.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}