import re
regex = re.compile(r"(?P<workspace>(@[\w-]*)?)//(?P<package>[\w\-/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\w\-\./]+)|(?P<target_recursive>\.\.\.)|(?P<empty_target>(?<!/)))$", flags=re.MULTILINE)
test_str = ("@saicny_robotics//devices/realsense:all\n"
"@saicny_robotics//devices/realsense/:all\n"
"@//devices/realsense/...\n"
"//...\n"
"@spybot//...\n"
"@spybot//:all\n"
"@spybot//devices/realsense\n"
"@spybot//devices/realsense/\n"
"@spybot//:path/to\n"
"@spybot//devices/realsense:path_to/file.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")