const regex = new RegExp('(?P<workspace>(@[\\w-]*)?)//(?P<package>[\\w\\-/]*)(?P<target>:(?P<target_all>all)|:(?P<target_named>[\\w\\-\\./]+)|(?P<target_recursive>\\.\\.\\.)|(?P<empty_target>(?<!/)))$', 'gm')
const str = `@saicny_robotics//devices/realsense:all
@saicny_robotics//devices/realsense/:all
@//devices/realsense/...
//...
@spybot//...
@spybot//:all
@spybot//devices/realsense
@spybot//devices/realsense/
@spybot//:path/to
@spybot//devices/realsense:path_to/file.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}