#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?"
Local $sString = "PLOAD4,105,5686,1.091300E+05,,,,," & @CRLF & _
"PLOAD4,105,5686,-1.912900E+05,,,,," & @CRLF & _
"" & @CRLF & _
"8243965,81.8897" & @CRLF & _
"8243965,-18.2857" & @CRLF & _
"" & @CRLF & _
"7,P,-101761" & @CRLF & _
"7,P,1671011" & @CRLF & _
"" & @CRLF & _
"177842,P,-100588" & @CRLF & _
"177842,P,912598" & @CRLF & _
"" & @CRLF & _
"*DLOAD" & @CRLF & _
"*TEMPERATURE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")